16:02:55 <Eighth_Doctor> #startmeeting Hyperscale SIG
16:02:55 <centguard> Meeting started Wed Sep 14 16:02:55 2022 UTC. The chair is Eighth_Doctor. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:55 <centguard> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:02:55 <centguard> The meeting name has been set to 'hyperscale_sig'
16:03:17 <Eighth_Doctor> #chair davide Davide Cavalca
16:03:17 <centguard> Current chairs: Cavalca Davide Eighth_Doctor davide
16:04:21 <Eighth_Doctor> let's give a couple of minutes to see if any more folks trickle in
16:05:09 * davide is attending LPC and will be sporadic today
16:05:55 <Eighth_Doctor> well, let's get started
16:06:01 <neil> heya, folks
16:06:05 <kcwells> Howdy
16:06:23 <Eighth_Doctor> #topic Followups
16:07:32 <Eighth_Doctor> I've been working with arrfab on getting the kiwi plugin activated on CBS
16:07:41 <Eighth_Doctor> we've made good progress on validating it on the staging CBS
16:08:08 <Eighth_Doctor> the koji developers have made a couple of fixes that need to be backported to the package in EPEL for CBS, but we should be otherwise in good shape
16:08:49 <Eighth_Doctor> however, we have learned that CentOS infra is not prepared yet to deploy anything on CentOS Stream 9, which makes getting Btrfs support for building disk images in CBS harder
16:09:11 <Eighth_Doctor> the only option we have for CentOS Stream 8 is the Hyperscale kernel, we did a bunch of work in Stream 9 to make it possible for kmod-btrfs to work
16:10:06 <Eighth_Doctor> so we're probably going to be restricted from providing cloud images until this is resolved
16:10:20 <Eighth_Doctor> or arm images too, for that matter
16:10:42 <Eighth_Doctor> that's it for me
16:10:51 <Eighth_Doctor> are there any other followups from anyone?
16:12:05 <Eighth_Doctor> if not, then...
16:12:12 <Eighth_Doctor> let's move to...
16:12:16 <Eighth_Doctor> #topic Announcements
16:12:51 <Eighth_Doctor> does anyone have anything for announcements?
16:12:59 <Eighth_Doctor> I've got nothing...
16:13:16 <neil> not I. thanks for the update on the koji/kiwi stuff
16:13:53 <Eighth_Doctor> alright, let's move to...
16:13:59 <Eighth_Doctor> #topic Tickets
16:14:32 <Eighth_Doctor> We don't have any new tickets tagged for meeting
16:15:23 <Eighth_Doctor> so, let's move on to...
16:15:25 <Eighth_Doctor> #topic Membership
16:16:35 <Eighth_Doctor> We have one ticket for membership for Richard Phibel from Meta
16:16:45 <Eighth_Doctor> #link https://pagure.io/centos-sig-hyperscale/sig/issue/128
16:17:05 <Eighth_Doctor> is Richard here today?
16:17:56 <kcwells> What will Richard be focusing on?
16:18:39 <davide> he's currently working on backporting hidepid in the c8s kernel so we can drop the workaround we currently have in systemd
16:19:00 <kcwells> Cool
16:19:04 <kcwells> +1
16:19:07 <tdmackey> +1
16:19:17 <Eighth_Doctor> I'm fine with it too +1
16:19:24 <Eighth_Doctor> I would like a proper intro from him at some point though
16:19:32 <aekoroglu> +1
16:19:36 <oidoming> +1
16:19:41 <davide> yeah I'll ask him to join the next meeting, I think he was having some trouble with IRC
16:19:42 <aekoroglu> sorry I'm late
16:19:55 <neil> o/ aekoroglu
16:20:01 <Eighth_Doctor> aekoroglu: hey, no worries
16:20:01 <davide> +1 for the record :)
16:20:28 <Eighth_Doctor> #agreed Richard Phibel (FAS/ACO: richardphibel) is accepted into the Hyperscale SIG
16:20:50 <Eighth_Doctor> Davide Cavalca: do you want to take care of the button pushing for this?
16:21:03 <davide> yeah I'll do that once things quiet down here, thanks
16:21:12 <salimma> o/
16:21:20 <salimma> sorry, got held up with other matters
16:21:39 <Eighth_Doctor> #action Davide Cavalca will add Richard Phibel (FAS/ACO: richardphibel) to the Hyperscale SIG
16:21:59 <Eighth_Doctor> That's it for membership, so...
16:22:14 <Eighth_Doctor> #topic Misc
16:22:35 <Eighth_Doctor> Is there anything else anyone wanted to bring up to discuss?
16:22:47 <davide> Meta will be doing some work on qemu
16:22:58 <davide> that will hopefully help to get a package in epel down the road
16:23:01 <Eighth_Doctor> Oh yay!
16:23:03 <neil> :D
16:23:14 <davide> I did some prep work for that earlier this week
16:23:20 <Eighth_Doctor> That might give me a reason to maintain a libvirt package in Hyperscale again
16:23:30 <Eighth_Doctor> depending on what extra features we might want from qemu exposed in libvirt
16:23:51 <davide> https://src.fedoraproject.org/rpms/qemu/pull-request/28#comment-115808 has a quick summary
16:23:53 <Eighth_Doctor> I haven't bothered since Red Hat started updating libvirt fairly aggressively in both c8s and c9s
16:23:55 <kcwells> Neat
16:24:00 <aekoroglu> using spice again :)
16:24:50 <Eighth_Doctor> yeah, that's a solid motivator
16:24:58 <Eighth_Doctor> it also means GNOME Boxes will work in EPEL :)
16:25:14 <Eighth_Doctor> (GNOME Boxes requires SPICE)
16:25:22 <davide> note that for EPEL there's some pretty significant blockers at the moment
16:25:30 <neil> i for one support this change aggressively
16:25:31 <davide> https://bugzilla.redhat.com/show_bug.cgi?id=2125336 being the main one
16:25:35 <Eighth_Doctor> do you have a bug tree for that yet?
16:25:53 <davide> I will once this is properly scoped out and I have build working end to end
16:26:05 <davide> probably some time later this month
16:26:44 <Eighth_Doctor> excellent
16:26:50 <Eighth_Doctor> that will give us something solid to track
16:27:07 <Eighth_Doctor> it does remind me that I should bring up that we're getting really close to being able to ship ffmpeg in EPEL 9
16:27:15 <Eighth_Doctor> The tracking bug for that is here: https://bugzilla.redhat.com/show_bug.cgi?id=2053866
16:27:46 <Eighth_Doctor> as part of Hyperscale SIG work I did earlier in the year, I've gotten the necessary RHEL-side dependencies exposed
16:27:55 <Eighth_Doctor> they'll ship with RHEL 9.1 in a couple of months
16:27:58 <davide> on a related note, there's something odd going on with epel8 in cbs as some packages seem to be missing, see https://cbs.centos.org/koji/taskinfo?taskID=3003503 for an example
16:28:00 <Eighth_Doctor> and they're in c9s now
16:28:04 <davide> I haven't had time to rootcause this
16:28:42 <Eighth_Doctor> Davide Cavalca: oh dear
16:28:43 <Eighth_Doctor> wonder if there's some kind of inheritance masking thing?
16:28:53 <davide> yeah not sure
16:29:13 <Eighth_Doctor> iirc, the buildroot repo should be available in CBS tags
16:29:29 <davide> the tag inheritance seems to agree, yes
16:29:43 <aekoroglu> No matching package to install: 'python3-virt-firmware'
16:29:45 <Eighth_Doctor> do you have an issue filed about this yet?
16:29:53 <Eighth_Doctor> or are you trying to figure that out first?
16:30:03 <davide> no, wanted to poke some more to avoid wasting people time
16:30:14 <Eighth_Doctor> python3-virt-firmware is in EPEL 8
16:30:15 <davide> feel free to look at it if you'd like
16:30:25 <Eighth_Doctor> so I'm very confused now
16:30:34 <davide> yup
16:30:49 <davide> that's where I stopped too :)
16:31:00 <aekoroglu> :))
16:31:06 <Eighth_Doctor> well, then
16:32:06 <Eighth_Doctor> going back to the ffmpeg thing, if other members of Hyperscale could help get EPEL dependencies in place in EPEL 9, that'd be fantastic
16:32:37 <Eighth_Doctor> decathorpe from the Fedora Rust SIG would love help with getting the Rust crates branched and updated in EPEL 9 to build rav1e
16:33:02 <Eighth_Doctor> for example
16:33:59 <Eighth_Doctor> and also frei0r-plugins and opencv still need to be branched and built in EPEL 9
16:34:57 <Eighth_Doctor> once everything is all said and done, this ffmpeg and the gstreamer1-plugin-libav packages will add significant multimedia capabilities to RHEL/CentOS systems
16:35:19 <aekoroglu> yeah I would love to help
16:35:30 <Eighth_Doctor> and for folks doing video production stuff, this ffmpeg will have support for as much hardware acceleration as RHEL supports
16:35:31 <aekoroglu> we dont have R mass build anymore :)
16:35:36 <neil> i'd love to follow along and see what all is involved
16:35:53 <neil> have been wanting to dip my toes in for awhile
16:36:14 <salimma> oh, having more Rust crates will be nice
16:36:20 <Eighth_Doctor> (and yes, this means AMD and NVIDIA too)
16:36:33 <Eighth_Doctor> as well as Intel QSV
16:36:48 <salimma> we have a lot of crates in Fedora that we're sort of unsure if we should mass-branch them for epel9 and chase dependencies, or not
16:36:59 <Eighth_Doctor> no oneVPL sadly, since Fedora doesn't have it yet
16:37:07 <salimma> if decathorpe is doing the rav1e deps then let's get them all branched
16:37:23 <Eighth_Doctor> decathorpe won't be able to start until after his thesis is done in late October
16:37:32 <Eighth_Doctor> so if anyone wants to help, he would appreciate it
16:37:58 <Eighth_Doctor> https://bugzilla.redhat.com/show_bug.cgi?id=2124924
16:39:18 <aekoroglu> I think I should attend some EPEL SIG meetings :)
16:39:45 <salimma> we should file bugs even though rust sig has permission anyway, right? just for tracking
16:39:55 <salimma> aekoroglu: next meeting is in 3.5 hours :)
16:39:55 <Eighth_Doctor> there should be one later today at 4pm EDT
16:40:12 <aekoroglu> :) deal I'll be there
16:40:14 <Eighth_Doctor> 20:00 (8pm) UTC
16:40:55 <Eighth_Doctor> Michel Alexandre Salim 🎩: yes, filing bugs to track the chain would be useful
16:41:10 <Eighth_Doctor> once ffmpeg is in EPEL, mpv can be added to EPEL too
16:41:25 <Eighth_Doctor> and in the future (when vlc 4.0 is released), we can add VLC to Fedora + EPEL
16:41:53 <aekoroglu> VLC in fedora nice :)
16:41:55 <Eighth_Doctor> (vlc 4.0 will support ffmpeg 5.x)
16:42:32 <Eighth_Doctor> https://code.videolan.org/videolan/vlc/-/milestones/103
16:42:43 <Eighth_Doctor> it's "due" at the end of the year
16:43:43 <aekoroglu> BTW do we have any plan for fosdem? https://fosdem.org/2022/news/2022-09-14-fosdem-2023-dates/
16:44:35 <Eighth_Doctor> I don't know... Davide Cavalca?
16:44:57 <davide> oh it's official now
16:45:02 <davide> I'll probably be there
16:45:13 <aekoroglu> they said "we are aiming for a physical FOSDEM 2023. It's both exciting and scary."
16:45:15 <davide> and there was talk of doing a Dojo but nothing official yet
16:45:36 <davide> assuming the world doesn't go insane again obviously
16:48:43 <Eighth_Doctor> we'll see...
16:49:00 <Eighth_Doctor> well, I think that's everything, so if there's nothing else, I'll close in...
16:49:05 <Eighth_Doctor> 5
16:49:11 <oidoming> hey guys I have something
16:49:15 <salimma> oh they have dates! yay
16:49:18 * salimma needs to apply for Schengen
16:49:18 <Eighth_Doctor> oh?
16:49:18 <aekoroglu> I booked my ticket today, worst case scenario is belgian beer for a weekend :)
16:49:29 <oidoming> Made new PR for auto close issues for package-updates https://pagure.io/centos-sig-hyperscale/package-updates/pull-request/29 https://pagure.io/centos-sig-hyperscale/sig/issue/114
16:49:38 <salimma> aekoroglu: does Intel still pay if the conference is cancelled?
16:49:39 <oidoming> I need to test it on openshift
16:50:13 <Eighth_Doctor> cool
16:50:34 <aekoroglu> Intel is not paying anything :)
16:50:40 <Eighth_Doctor> haha
16:50:49 <Eighth_Doctor> well, this is how you know I'm not going to be at FOSDEM
16:50:54 <Eighth_Doctor> nobody is going to pay for that for me :)
16:51:23 <davide> I'm sure whatever we end up doing will have a remote component
16:51:36 <kcwells> It helps that aekoroglu is already in Europe
16:51:39 <Eighth_Doctor> hopefully
16:51:48 <Eighth_Doctor> anyway, there's ten minutes between now and the Stream Office Hours
16:51:52 <aekoroglu> :)
16:52:09 <Eighth_Doctor> so unless there's anything else to bring up...?
16:52:39 <Eighth_Doctor> alright, thanks everyone for coming!
16:52:40 <Eighth_Doctor> #endmeeting